Directory Traversal Affecting cni package, versions <0.7.1-150000.1.7.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.53% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-CNI-3136571
  • published22 Nov 2022
  • disclosed21 Nov 2022

Introduced: 21 Nov 2022

CVE-2021-20206  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 cni to version 0.7.1-150000.1.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cni package and not the cni package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An improper limitation of path name flaw was found in containernetworking/cni in versions before 0.8.1. When specifying the plugin to load in the 'type' field in the network configuration, it is possible to use special elements such as "../" separators to reference binaries elsewhere on the system. This flaw allows an attacker to execute other existing binaries other than the cni plugins/types, such as 'reboot'. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

CVSS Base Scores

version 3.1