CVE-2020-10749 Affecting cni-plugins package, versions <0.8.6-150000.1.7.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
2.09% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-CNIPLUGINS-3136573
  • published22 Nov 2022
  • disclosed21 Nov 2022

Introduced: 21 Nov 2022

CVE-2020-10749  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 cni-plugins to version 0.8.6-150000.1.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cni-plugins package and not the cni-plugins package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A vulnerability was found in all versions of containernetworking/plugins before version 0.8.6, that allows malicious containers in Kubernetes clusters to perform man-in-the-middle (MitM) attacks. A malicious container can exploit this flaw by sending rogue IPv6 router advertisements to the host or other containers, to redirect traffic to the malicious container.

CVSS Base Scores

version 3.1