Directory Traversal Affecting dpkg-devel package, versions <1.19.0.4-150000.4.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.24% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-DPKGDEVEL-3127100
  • published19 Nov 2022
  • disclosed18 Nov 2022

Introduced: 18 Nov 2022

CVE-2022-1664  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 dpkg-devel to version 1.19.0.4-150000.4.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dpkg-devel package and not the dpkg-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Dpkg::Source::Archive in dpkg, the Debian package management system, before version 1.21.8, 1.20.10, 1.19.8, 1.18.26 is prone to a directory traversal vulnerability. When extracting untrusted source packages in v2 and v3 source package formats that include a debian.tar, the in-place extraction can lead to directory traversal situations on specially crafted orig.tar and debian.tar tarballs.

CVSS Base Scores

version 3.1