CVE-2019-10153 Affecting fence-agents-devel package, versions <4.4.0+git.1558595666.5f79f9e9-4.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.17% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-FENCEAGENTSDEVEL-2636668
  • published14 Apr 2022
  • disclosed10 Jul 2019

Introduced: 10 Jul 2019

CVE-2019-10153  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 fence-agents-devel to version 4.4.0+git.1558595666.5f79f9e9-4.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fence-agents-devel package and not the fence-agents-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A flaw was discovered in fence-agents, prior to version 4.3.4, where using non-ASCII characters in a guest VM's comment or other fields would cause fence_rhevm to exit with an exception. In cluster environments, this could lead to preventing automated recovery or otherwise denying service to clusters of which that VM is a member.

CVSS Base Scores

version 3.1