Use After Free Affecting gdm-devel package, versions <3.26.2.1-13.9.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.54% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-GDMDEVEL-2761096
  • published14 Apr 2022
  • disclosed20 Sept 2018

Introduced: 20 Sep 2018

CVE-2018-14424  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 gdm-devel to version 3.26.2.1-13.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdm-devel package and not the gdm-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

The daemon in GDM through 3.29.1 does not properly unexport display objects from its D-Bus interface when they are destroyed, which allows a local attacker to trigger a use-after-free via a specially crafted sequence of D-Bus method calls, resulting in a denial of service or potential code execution.