Cross-site Request Forgery (CSRF) Affecting gpg2 package, versions <2.2.5-4.6.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.04% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-GPG2-2755806
  • published14 Apr 2022
  • disclosed7 Jan 2019

Introduced: 7 Jan 2019

CVE-2018-1000858  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 gpg2 to version 2.2.5-4.6.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gpg2 package and not the gpg2 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

GnuPG version 2.1.12 - 2.2.11 contains a Cross ite Request Forgery (CSRF) vulnerability in dirmngr that can result in Attacker controlled CSRF, Information Disclosure, DoS. This attack appear to be exploitable via Victim must perform a WKD request, e.g. enter an email address in the composer window of Thunderbird/Enigmail. This vulnerability appears to have been fixed in after commit 4a4bb874f63741026bd26264c43bb32b1099f060.