Incorrect Default Permissions Affecting gvfs-backend-samba package, versions <1.34.2.1-4.13.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-GVFSBACKENDSAMBA-2745528
  • published14 Apr 2022
  • disclosed1 Jul 2019

Introduced: 1 Jul 2019

CVE-2019-12795  (opens in a new tab)
CWE-276  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 gvfs-backend-samba to version 1.34.2.1-4.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gvfs-backend-samba package and not the gvfs-backend-samba package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

daemon/gvfsdaemon.c in gvfsd from GNOME gvfs before 1.38.3, 1.40.x before 1.40.2, and 1.41.x before 1.41.3 opened a private D-Bus server socket without configuring an authorization rule. A local attacker could connect to this server socket and issue D-Bus method calls. (Note that the server socket only accepts a single connection, so the attacker would have to discover the server and connect to the socket before its owner does.)

CVSS Base Scores

version 3.1