Out-of-bounds Read Affecting ImageMagick-config-7-SUSE package, versions <7.0.7.34-3.54.3


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.96% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-IMAGEMAGICKCONFIG7SUSE-2755085
  • published14 Apr 2022
  • disclosed24 Apr 2019

Introduced: 24 Apr 2019

CVE-2019-11007  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 ImageMagick-config-7-SUSE to version 7.0.7.34-3.54.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ImageMagick-config-7-SUSE package and not the ImageMagick-config-7-SUSE package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In GraphicsMagick 1.4 snapshot-20190322 Q8, there is a heap-based buffer over-read in the ReadMNGImage function of coders/png.c, which allows attackers to cause a denial of service or information disclosure via an image colormap.

CVSS Base Scores

version 3.1