Out-of-bounds Write Affecting ImageMagick-config-7-upstream package, versions <7.0.7.34-3.67.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.73% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-IMAGEMAGICKCONFIG7UPSTREAM-2745261
  • published14 Apr 2022
  • disclosed9 Aug 2019

Introduced: 9 Aug 2019

CVE-2019-13308  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 ImageMagick-config-7-upstream to version 7.0.7.34-3.67.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ImageMagick-config-7-upstream package and not the ImageMagick-config-7-upstream package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

ImageMagick 7.0.8-50 Q16 has a heap-based buffer overflow in MagickCore/fourier.c in ComplexImage.

CVSS Base Scores

version 3.1