Out-of-bounds Read Affecting libasm1 package, versions <0.168-4.5.3


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.75% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBASM1-2748596
  • published14 Apr 2022
  • disclosed13 Jun 2019

Introduced: 13 Jun 2019

CVE-2017-7611  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libasm1 to version 0.168-4.5.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libasm1 package and not the libasm1 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

The check_symtab_shndx function in elflint.c in elfutils 0.168 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted ELF file.