CVE-2016-3189 Affecting libbz2-1 package, versions <1.0.6-5.3.1


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
15.69% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBBZ21-2754705
  • published14 Apr 2022
  • disclosed10 May 2019

Introduced: 10 May 2019

CVE-2016-3189  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libbz2-1 to version 1.0.6-5.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libbz2-1 package and not the libbz2-1 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Use-after-free vulnerability in bzip2recover in bzip2 1.0.6 allows remote attackers to cause a denial of service (crash) via a crafted bzip2 file, related to block ends set to before the start of the block.

References

CVSS Base Scores

version 3.1