Out-of-Bounds Affecting libcaca-devel package, versions <0.99.beta19.git20171003-3.3.7


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.8% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBCACADEVEL-2752895
  • published14 Apr 2022
  • disclosed27 Mar 2019

Introduced: 27 Mar 2019

CVE-2018-20547  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libcaca-devel to version 0.99.beta19.git20171003-3.3.7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcaca-devel package and not the libcaca-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

There is an illegal READ memory access at caca/dither.c (function get_rgba_default) in libcaca 0.99.beta19 for 24bpp data.

CVSS Base Scores

version 3.1