Out-of-Bounds Affecting libcom_err-devel package, versions <1.43.8-4.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.89% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBCOMERRDEVEL-2763091
  • published14 Apr 2022
  • disclosed19 Jul 2018

Introduced: 19 Jul 2018

CVE-2015-0247  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libcom_err-devel to version 1.43.8-4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcom_err-devel package and not the libcom_err-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Heap-based buffer overflow in openfs.c in the libext2fs library in e2fsprogs before 1.42.12 allows local users to execute arbitrary code via crafted block group descriptor data in a filesystem image.

CVSS Base Scores

version 3.1