Out-of-bounds Read Affecting libcom_err-devel package, versions <1.43.8-150000.4.33.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.47% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBCOMERRDEVEL-2825312
  • published17 May 2022
  • disclosed16 May 2022

Introduced: 16 May 2022

CVE-2022-1304  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libcom_err-devel to version 1.43.8-150000.4.33.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcom_err-devel package and not the libcom_err-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An out-of-bounds read/write vulnerability was found in e2fsprogs 1.46.5. This issue leads to a segmentation fault and possibly arbitrary code execution via a specially crafted filesystem.

CVSS Base Scores

version 3.1