Out-of-bounds Read Affecting libhdf5hl_fortran_1_10_8-gnu-hpc package, versions <1.10.8-150000.8.4.3


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.27% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBHDF5HLFORTRAN1108GNUHPC-2856017
  • published3 Jun 2022
  • disclosed2 Jun 2022

Introduced: 2 Jun 2022

CVE-2017-17506  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libhdf5hl_fortran_1_10_8-gnu-hpc to version 1.10.8-150000.8.4.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libhdf5hl_fortran_1_10_8-gnu-hpc package and not the libhdf5hl_fortran_1_10_8-gnu-hpc package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In HDF5 1.10.1, there is an out of bounds read vulnerability in the function H5Opline_pline_decode in H5Opline.c in libhdf5.a. For example, h5dump would crash when someone opens a crafted hdf5 file.

CVSS Base Scores

version 3.1