Use After Free Affecting liblouis-devel package, versions <3.3.0-4.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.87% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBLOUISDEVEL-2756121
  • published14 Apr 2022
  • disclosed28 Mar 2019

Introduced: 28 Mar 2019

CVE-2018-11410  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 liblouis-devel to version 3.3.0-4.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis-devel package and not the liblouis-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An issue was discovered in Liblouis 3.5.0. A invalid free in the compileRule function in compileTranslationTable.c allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.