Use After Free Affecting liblua5_3-5-32bit package, versions <5.3.4-3.3.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
17.36% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBLUA53532BIT-2756593
  • published14 Apr 2022
  • disclosed6 Feb 2019

Introduced: 6 Feb 2019

CVE-2019-6706  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 liblua5_3-5-32bit to version 5.3.4-3.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblua5_3-5-32bit package and not the liblua5_3-5-32bit package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Lua 5.3.5 has a use-after-free in lua_upvaluejoin in lapi.c. For example, a crash outcome might be achieved by an attacker who is able to trigger a debug.upvaluejoin call in which the arguments have certain relationships.

CVSS Base Scores

version 3.1