Out-of-bounds Write Affecting liblz4-devel package, versions <1.8.0-3.5.1


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
10.45% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBLZ4DEVEL-2729566
  • published14 Apr 2022
  • disclosed23 Oct 2019

Introduced: 23 Oct 2019

CVE-2019-17543  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 liblz4-devel to version 1.8.0-3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblz4-devel package and not the liblz4-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states "only a few specific / uncommon usages of the API are at risk."

References

CVSS Base Scores

version 3.1