Out-of-Bounds Affecting libMagick++-7_Q16HDRI4 package, versions <7.0.7.34-3.24.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.65% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBMAGICK7Q16HDRI4-2760629
  • published14 Apr 2022
  • disclosed2 Oct 2018

Introduced: 2 Oct 2018

CVE-2018-16644  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libMagick++-7_Q16HDRI4 to version 7.0.7.34-3.24.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libMagick++-7_Q16HDRI4 package and not the libMagick++-7_Q16HDRI4 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

There is a missing check for length in the functions ReadDCMImage of coders/dcm.c and ReadPICTImage of coders/pict.c in ImageMagick 7.0.8-11, which allows remote attackers to cause a denial of service via a crafted image.