Memory Leak Affecting libMagick++-devel package, versions <7.0.7.34-3.67.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.7% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBMAGICKDEVEL-2745995
  • published14 Apr 2022
  • disclosed9 Aug 2019

Introduced: 9 Aug 2019

CVE-2019-13309  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libMagick++-devel to version 7.0.7.34-3.67.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libMagick++-devel package and not the libMagick++-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

ImageMagick 7.0.8-50 Q16 has memory leaks at AcquireMagickMemory because of mishandling the NoSuchImage error in CLIListOperatorImages in MagickWand/operation.c.

CVSS Base Scores

version 3.1