Out-of-bounds Read Affecting libnetpbm11 package, versions <10.80.1-3.8.2


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.65% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBNETPBM11-2747031
  • published14 Apr 2022
  • disclosed17 Jun 2019

Introduced: 17 Jun 2019

CVE-2017-2579  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libnetpbm11 to version 10.80.1-3.8.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libnetpbm11 package and not the libnetpbm11 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An out-of-bounds read vulnerability was found in netpbm before 10.61. The expandCodeOntoStack() function has an insufficient code value check, so that a maliciously crafted file could cause the application to crash or possibly allows code execution.