Out-of-bounds Read Affecting libnetpbm-devel package, versions <10.80.1-3.3.36


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.66% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBNETPBMDEVEL-2754827
  • published14 Apr 2022
  • disclosed3 Apr 2019

Introduced: 3 Apr 2019

CVE-2018-8975  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libnetpbm-devel to version 10.80.1-3.3.36 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libnetpbm-devel package and not the libnetpbm-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

The pm_mallocarray2 function in lib/util/mallocvar.c in Netpbm through 10.81.03 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, as demonstrated by pbmmask.