Use After Free Affecting libpacemaker3 package, versions <1.1.18+20180430.b12c320f5-3.9.4


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.9% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBPACEMAKER3-2754603
  • published14 Apr 2022
  • disclosed10 May 2019

Introduced: 10 May 2019

CVE-2019-3885  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libpacemaker3 to version 1.1.18+20180430.b12c320f5-3.9.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpacemaker3 package and not the libpacemaker3 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A use-after-free flaw was found in pacemaker up to and including version 2.0.1 which could result in certain sensitive information to be leaked via the system logs.