Out-of-Bounds Affecting libpango-1_0-0-32bit package, versions <1.40.14-3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
11.36% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBPANGO10032BIT-2761197
  • published14 Apr 2022
  • disclosed20 Sept 2018

Introduced: 20 Sep 2018

CVE-2018-15120  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libpango-1_0-0-32bit to version 1.40.14-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpango-1_0-0-32bit package and not the libpango-1_0-0-32bit package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.

CVSS Base Scores

version 3.1