Allocation of Resources Without Limits or Throttling Affecting libpcap1 package, versions <1.8.1-4.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.83% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBPCAP1-2731806
  • published14 Apr 2022
  • disclosed15 Oct 2019

Introduced: 15 Oct 2019

CVE-2019-15165  (opens in a new tab)
CWE-770  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libpcap1 to version 1.8.1-4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap1 package and not the libpcap1 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

sf-pcapng.c in libpcap before 1.9.1 does not properly validate the PHB header length before allocating memory.

References

CVSS Base Scores

version 3.1