Integer Overflow or Wraparound Affecting libpixman-1-0 package, versions <0.34.0-150000.7.5.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.91% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBPIXMAN10-3136585
  • published22 Nov 2022
  • disclosed21 Nov 2022

Introduced: 21 Nov 2022

CVE-2022-44638  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libpixman-1-0 to version 0.34.0-150000.7.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpixman-1-0 package and not the libpixman-1-0 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In libpixman in Pixman before 0.42.2, there is an out-of-bounds write (aka heap-based buffer overflow) in rasterize_edges_8 due to an integer overflow in pixman_sample_floor_y.

CVSS Base Scores

version 3.1