Race Condition Affecting libpmi0_18_08 package, versions <18.08.9-1.11.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.83% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBPMI01808-2693279
  • published14 Apr 2022
  • disclosed18 Dec 2020

Introduced: 18 Dec 2020

CVE-2020-27746  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libpmi0_18_08 to version 18.08.9-1.11.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpmi0_18_08 package and not the libpmi0_18_08 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Slurm before 19.05.8 and 20.x before 20.02.6 exposes Sensitive Information to an Unauthorized Actor because xauth for X11 magic cookies is affected by a race condition in a read operation on the /proc filesystem.

CVSS Base Scores

version 3.1