Out-of-bounds Write Affecting libraw16 package, versions <0.18.9-3.8.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.98% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBRAW16-2756932
  • published14 Apr 2022
  • disclosed21 Jan 2019

Introduced: 21 Jan 2019

CVE-2018-20365  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libraw16 to version 0.18.9-3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw16 package and not the libraw16 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

LibRaw::raw2image() in libraw_cxx.cpp has a heap-based buffer overflow.