Integer Overflow or Wraparound Affecting libraw16 package, versions <0.18.9-3.5.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.21% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBRAW16-2757621
  • published14 Apr 2022
  • disclosed2 Jan 2019

Introduced: 2 Jan 2019

CVE-2018-5815  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libraw16 to version 0.18.9-3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw16 package and not the libraw16 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An integer overflow error within the "parse_qt()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.12 can be exploited to trigger an infinite loop via a specially crafted Apple QuickTime file.