Out-of-bounds Write Affecting libraw-devel package, versions <0.18.9-3.8.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.15% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBRAWDEVEL-2758847
  • published14 Apr 2022
  • disclosed21 Jan 2019

Introduced: 21 Jan 2019

CVE-2018-20337  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libraw-devel to version 0.18.9-3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw-devel package and not the libraw-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

There is a stack-based buffer overflow in the parse_makernote function of dcraw_common.cpp in LibRaw 0.19.1. Crafted input will lead to a denial of service or possibly unspecified other impact.