Improper Input Validation Affecting libspice-controller0 package, versions <0.34-3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.93% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBSPICECONTROLLER0-2761416
  • published14 Apr 2022
  • disclosed13 Sept 2018

Introduced: 13 Sep 2018

CVE-2018-10873  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libspice-controller0 to version 0.34-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libspice-controller0 package and not the libspice-controller0 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.