Off-by-one Error Affecting libspice-server1 package, versions <0.14.0-4.6.2


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.21% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBSPICESERVER1-2758495
  • published14 Apr 2022
  • disclosed5 Feb 2019

Introduced: 5 Feb 2019

CVE-2019-3813  (opens in a new tab)
CWE-193  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libspice-server1 to version 0.14.0-4.6.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libspice-server1 package and not the libspice-server1 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.

CVSS Base Scores

version 3.1