OS Command Injection Affecting libssh4 package, versions <0.7.5-6.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.17% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBSSH4-2720908
  • published14 Apr 2022
  • disclosed13 Dec 2019

Introduced: 13 Dec 2019

CVE-2019-14889  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libssh4 to version 0.7.5-6.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libssh4 package and not the libssh4 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A flaw was found with the libssh API function ssh_scp_new() in versions before 0.9.3 and before 0.8.8. When the libssh SCP client connects to a server, the scp command, which includes a user-provided path, is executed on the server-side. In case the library is used in a way where users can influence the third parameter of the function, it would become possible for an attacker to inject arbitrary commands, leading to a compromise of the remote target.

CVSS Base Scores

version 3.1