Improper Authentication Affecting libssh4-32bit package, versions <0.7.5-6.3.1


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
91.79% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBSSH432BIT-2761746
  • published14 Apr 2022
  • disclosed16 Oct 2018

Introduced: 16 Oct 2018

CVE-2018-10933  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libssh4-32bit to version 0.7.5-6.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libssh4-32bit package and not the libssh4-32bit package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A vulnerability was found in libssh's server-side state machine before versions 0.7.6 and 0.8.4. A malicious client could create channels without first performing authentication, resulting in unauthorized access.