Out-of-bounds Read Affecting libvorbis0 package, versions <1.3.6-4.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.32% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBVORBIS0-2762012
  • published14 Apr 2022
  • disclosed5 Jul 2018

Introduced: 5 Jul 2018

CVE-2018-10392  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libvorbis0 to version 1.3.6-4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libvorbis0 package and not the libvorbis0 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

mapping0_forward in mapping0.c in Xiph.Org libvorbis 1.3.6 does not validate the number of channels, which allows remote attackers to cause a denial of service (heap-based buffer overflow or over-read) or possibly have unspecified other impact via a crafted file.

CVSS Base Scores

version 3.1