Out-of-bounds Read Affecting libwavpack1 package, versions <5.1.0-4.3.5


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.46% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBWAVPACK1-2754234
  • published14 Apr 2022
  • disclosed27 Mar 2019

Introduced: 27 Mar 2019

CVE-2018-19841  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libwavpack1 to version 5.1.0-4.3.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libwavpack1 package and not the libwavpack1 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

The function WavpackVerifySingleBlock in open_utils.c in libwavpack.a in WavPack through 5.1.0 allows attackers to cause a denial-of-service (out-of-bounds read and application crash) via a crafted WavPack Lossless Audio file, as demonstrated by wvunpack.

References

CVSS Base Scores

version 3.1