Loop with Unreachable Exit Condition ('Infinite Loop') Affecting libwsman3 package, versions <2.6.7-3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
15.24% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBWSMAN3-2755399
  • published14 Apr 2022
  • disclosed20 Mar 2019

Introduced: 20 Mar 2019

CVE-2019-3833  (opens in a new tab)
CWE-835  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libwsman3 to version 2.6.7-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libwsman3 package and not the libwsman3 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Openwsman, versions up to and including 2.6.9, are vulnerable to infinite loop in process_connection() when parsing specially crafted HTTP requests. A remote, unauthenticated attacker can exploit this vulnerability by sending malicious HTTP request to cause denial of service to openwsman server.

CVSS Base Scores

version 3.1