Off-by-one Error Affecting libX11-devel package, versions <1.6.5-3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.21% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBX11DEVEL-2759050
  • published14 Apr 2022
  • disclosed30 Sept 2018

Introduced: 30 Sep 2018

CVE-2018-14599  (opens in a new tab)
CWE-193  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libX11-devel to version 1.6.5-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libX11-devel package and not the libX11-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An issue was discovered in libX11 through 1.6.5. The function XListExtensions in ListExt.c is vulnerable to an off-by-one error caused by malicious server responses, leading to DoS or possibly unspecified other impact.

CVSS Base Scores

version 3.1