Directory Traversal Affecting libzzip-0-13 package, versions <0.13.69-3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.54% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LIBZZIP013-2760157
  • published14 Apr 2022
  • disclosed18 Oct 2018

Introduced: 18 Oct 2018

CVE-2018-17828  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 libzzip-0-13 to version 0.13.69-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libzzip-0-13 package and not the libzzip-0-13 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Directory traversal vulnerability in ZZIPlib 0.13.69 allows attackers to overwrite arbitrary files via a .. (dot dot) in a zip file, because of the function unzzip_cat in the bins/unzzipcat-mem.c file.