Integer Overflow or Wraparound Affecting lz4 package, versions <1.8.0-3.8.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.4% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-LZ4-2679060
  • published14 Apr 2022
  • disclosed19 May 2021

Introduced: 19 May 2021

CVE-2021-3520  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 lz4 to version 1.8.0-3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lz4 package and not the lz4 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

There's a flaw in lz4. An attacker who submits a crafted file to an application linked with lz4 may be able to trigger an integer overflow, leading to calling of memmove() on a negative size argument, causing an out-of-bounds write and/or a crash. The greatest impact of this flaw is to availability, with some potential impact to confidentiality and integrity as well.

CVSS Base Scores

version 3.1