Arbitrary Code Injection Affecting MozillaFirefox package, versions <68.1.0-3.54.2


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.57% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-MOZILLAFIREFOX-2736139
  • published14 Apr 2022
  • disclosed3 Oct 2019

Introduced: 3 Oct 2019

CVE-2019-9811  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 MozillaFirefox to version 68.1.0-3.54.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox package and not the MozillaFirefox package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

As part of a winning Pwn2Own entry, a researcher demonstrated a sandbox escape by installing a malicious language pack and then opening a browser feature that used the compromised translation. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

CVSS Base Scores

version 3.1