Arbitrary Code Injection Affecting MozillaFirefox package, versions <52.9.0esr-3.7.12


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
10.24% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-MOZILLAFIREFOX-2763029
  • published14 Apr 2022
  • disclosed10 Aug 2018

Introduced: 10 Aug 2018

CVE-2018-5158  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 MozillaFirefox to version 52.9.0esr-3.7.12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox package and not the MozillaFirefox package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

The PDF viewer does not sufficiently sanitize PostScript calculator functions, allowing malicious JavaScript to be injected through a crafted PDF file. This JavaScript can then be run with the permissions of the PDF viewer by its worker. This vulnerability affects Firefox ESR < 52.8 and Firefox < 60.