Insufficiently Protected Credentials Affecting MozillaFirefox-branding-SLE package, versions <60-4.5.3


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.46% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-MOZILLAFIREFOXBRANDINGSLE-2757921
  • published14 Apr 2022
  • disclosed25 Oct 2018

Introduced: 25 Oct 2018

CVE-2018-12383  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 MozillaFirefox-branding-SLE to version 60-4.5.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-branding-SLE package and not the MozillaFirefox-branding-SLE package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

If a user saved passwords before Firefox 58 and then later set a master password, an unencrypted copy of these passwords is still accessible. This is because the older stored password file was not deleted when the data was copied to a new format starting in Firefox 58. The new master password is added only on the new file. This could allow the exposure of stored password data outside of user expectations. This vulnerability affects Firefox < 62, Firefox ESR < 60.2.1, and Thunderbird < 60.2.1.