Out-of-Bounds Affecting MozillaFirefox-devel package, versions <52.9.0esr-3.7.12


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.89% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-MOZILLAFIREFOXDEVEL-2762431
  • published14 Apr 2022
  • disclosed10 Aug 2018

Introduced: 10 Aug 2018

CVE-2018-5178  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 MozillaFirefox-devel to version 52.9.0esr-3.7.12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-devel package and not the MozillaFirefox-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A buffer overflow was found during UTF8 to Unicode string conversion within JavaScript with extremely large amounts of data. This vulnerability requires the use of a malicious or vulnerable legacy extension in order to occur. This vulnerability affects Thunderbird ESR < 52.8, Thunderbird < 52.8, and Firefox ESR < 52.8.