Information Exposure Affecting MozillaFirefox-devel package, versions <52.9.0esr-3.7.12


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.58% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-MOZILLAFIREFOXDEVEL-2763940
  • published14 Apr 2022
  • disclosed10 Aug 2018

Introduced: 10 Aug 2018

CVE-2018-5157  (opens in a new tab)
CWE-200  (opens in a new tab)
CWE-346  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 MozillaFirefox-devel to version 52.9.0esr-3.7.12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-devel package and not the MozillaFirefox-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Same-origin protections for the PDF viewer can be bypassed, allowing a malicious site to intercept messages meant for the viewer. This could allow the site to retrieve PDF files restricted to viewing by an authenticated user on a third-party website. This vulnerability affects Firefox ESR < 52.8 and Firefox < 60.