Improper Input Validation Affecting MozillaFirefox-translations-other package, versions <60.2.2-3.13.3


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
9.59% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-MOZILLAFIREFOXTRANSLATIONSOTHER-2759769
  • published14 Apr 2022
  • disclosed25 Oct 2018

Introduced: 25 Oct 2018

CVE-2018-12387  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 MozillaFirefox-translations-other to version 60.2.2-3.13.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-translations-other package and not the MozillaFirefox-translations-other package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A vulnerability where the JavaScript JIT compiler inlines Array.prototype.push with multiple arguments that results in the stack pointer being off by 8 bytes after a bailout. This leaks a memory address to the calling function which can be used as part of an exploit inside the sandboxed content process. This vulnerability affects Firefox ESR < 60.2.2 and Firefox < 62.0.3.