Cross-site Request Forgery (CSRF) Affecting MozillaThunderbird package, versions <60.2.1-3.13.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.82% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-MOZILLATHUNDERBIRD-2760450
  • published14 Apr 2022
  • disclosed19 Oct 2018

Introduced: 19 Oct 2018

CVE-2018-12364  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 MozillaThunderbird to version 60.2.1-3.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaThunderbird package and not the MozillaThunderbird package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

NPAPI plugins, such as Adobe Flash, can send non-simple cross-origin requests, bypassing CORS by making a same-origin POST that does a 307 redirect to the target site. This allows for a malicious site to engage in cross-site request forgery (CSRF) attacks. This vulnerability affects Thunderbird < 60, Thunderbird < 52.9, Firefox ESR < 60.1, Firefox ESR < 52.9, and Firefox < 61.