Improper Input Validation Affecting MozillaThunderbird-translations-common package, versions <60.2.1-3.13.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.99% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-MOZILLATHUNDERBIRDTRANSLATIONSCOMMON-2761714
  • published14 Apr 2022
  • disclosed19 Oct 2018

Introduced: 19 Oct 2018

CVE-2018-12367  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 MozillaThunderbird-translations-common to version 60.2.1-3.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaThunderbird-translations-common package and not the MozillaThunderbird-translations-common package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In the previous mitigations for Spectre, the resolution or precision of various methods was reduced to counteract the ability to measure precise time intervals. In that work PerformanceNavigationTiming was not adjusted but it was found that it could be used as a precision timer. This vulnerability affects Thunderbird < 60, Firefox ESR < 60.1, and Firefox < 61.