Memory Leak Affecting opensc package, versions <0.18.0-150000.3.23.1


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.2% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-OPENSC-2637549
  • published14 Apr 2022
  • disclosed30 Mar 2022

Introduced: 30 Mar 2022

CVE-2019-6502  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 opensc to version 0.18.0-150000.3.23.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensc package and not the opensc package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

sc_context_create in ctx.c in libopensc in OpenSC 0.19.0 has a memory leak, as demonstrated by a call from eidenv.