CVE-2018-17953 Affecting pam-devel-32bit package, versions <1.3.0-6.6.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.34% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PAMDEVEL32BIT-2760546
  • published14 Apr 2022
  • disclosed3 Dec 2018

Introduced: 3 Dec 2018

CVE-2018-17953  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 pam-devel-32bit to version 1.3.0-6.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-devel-32bit package and not the pam-devel-32bit package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in openSUSE Leap 15.0 and SUSE Linux Enterprise 15 could lead to pam_access rules not being applied (fail open).